เมื่อช่วงสงกรานต์ทาง AIS Fibre ได้ส่ง SMS มาบอกว่าได้ upgrade speed ของคุณจาก 100/30Mbps เป็น 200/50Mbps ให้เป็นที่เรียบร้อย แต่ชำระค่าบริการรายเดือนเท่าเดิม หลังจาก Mikrotik RB450G ตัวเก่ามีปัญหา เมื่อวานตอน 2 ทุ่มจึงได้เวลาไปหา Mikrotik ตัวใหม่มาเปลี่ยนเป็นรุ่น RB850G ที่สเปกดีกว่าเดิม ตอนห้างเซียร์รังสิตกำลังจะปิด (อย่าคิดว่าตัวใหม่จะไม่พังอีกนะ 555+) และได้นำเอามา set up ใหม่โจทย์ใหม่ครั้งนี้ อยากได้ลองเล่น IPv6 บน AIS Fibre บ้าง และให้อุปกรณ์ในบ้านรองรับการทำงานบน IPv6 ทั้งหมด จึงได้เป็นที่มาของการเขียนบทความในครั้งนี้
ต้องขอออกตัวก่อนว่า ผมมีเวลาในการเตรียมอุปกรณ์และหาความรู้ไม่กี่ชั่วโมง หากมีข้อผิดพลาดประการใด แนะนำหรือชี้แนะผมมาได้เลยนะครับ เรามาเริ่ม config กันได้เลยครับ
ก่อนอื่นต้องอัพเกรด package บน mikrotik ให้รองรับ IPv6 ก่อนนะครับ ถ้ามีแล้วให้เลือก enable และจะได้ผลตามรูปที่ 1 ครับถ้ายังไม่มีให้ upload package ใหม่เข้าไปครับ

รูปที่ 1 แสดง package ipv6

เมื่อ package ipv6 บน mikrotik ได้รับการติดตั้งเรียบร้อย เริ่ม config ได้เลยครับ

ขั้นตอนที่ 1 ทำ pppoe-out รองรับการทำงานบน ipv6 โดยไปแก้ไขที่ ppp profile ครับ แล้วเลือก option ดังรูปที่ 2 ครับ ส่วนการตั้งค่า pppoe ให้ย้อนกลับไปดูบทความก่อนหน้านี้นะครับ Mikrotik กับ AIS Fibre แบบ Bridge mode ครับ

รูปที่ 2 เปิดการใช้งาน IPv6 และ Encryption บน PPP Profile

ขั้นตอนที่ 2 ทำการ config DHCP Client บน pppoe-out เพื่อร้องขอ IPv6 prefix จาก AIS Fibre ดังรูปที่ 3

รูปที่ 3 การตั้งค่า DHCPv6 Client

ขั้นตอนที่ 3 เมื่อทำการ config dhcp client แล้วกด apply ให้ตรวจสอบ status การร้องขอ prefix จาก AIS FIBRE จะได้ ดังรูปที่ 4

รูปที่ 4 แสดงสถานการร้อง prefix จาก AIS FIBRE และ Server Address

ขั้นตอนที่ 4 ทำการตรวจสอบจะบนว่าใน Pool ของเมนู IPv6 จะมี Pool ชื่อว่า AIS_IPv6_Pool ปรากฎขึ้นดังรูปที่ 5

รูปที่ 5 แสดง AIS_IPv6_Pool ในเมนู IPv6 Pool

ขั้นตอนที่ 5 ตั้งค่า ppp profile  ในส่วนของ DHCPv6 PD Pool กับ AIS_IPv6_Pool ดังรูปที่ 6

ขั้นตอนที่ 6 ทำการเพิ่ง Address ในส่วนของ IPv6 เพื่อให้สามารถ DHCP prefix ไปยังเครื่องภายใน Network ภายในซึ่งในภาพจะชื่อว่า “LAN_Bridge01” ได้ ดังรูปที่ 7

รูปที่ 7 แสดงการตั้งค่า IPv6 Address เพื่อให้ prefix จาก AIS FIBRE สามารรใช้งานได้ใน Local Area Network

เมื่อตั้งค่าตามขั้นตอนที่ ให้เข้าไปตรวจสอบค่าใน Address IPv6 จะได้ค่าดังรูปที่ 8

รูปที่ 8 แสดง IPv6 Address หลังจากตั้งค่าในขั้นตอนที่ 6

ขั้นตอนที่ 7 ตั้งค่า ND ตามรูปที่ 9

รูปที่ 9 แสดงการตั้งค่า ND

เมื่อทำการตั้งค่าเสร็จทุกขั้นตอน ซึ่งจะได้ config ดังนี้ครับ เพื่อนๆ ลองเอาไปปรับแก้ใช้กันดูนะครับ
# jun/22/2018 09:44:33 by RouterOS 6.42.4
# software id = 2H9M-QVQC
#
# model = 850Gx2

/interface bridge
add igmp-snooping=yes name=LAN_bridge01

/interface ethernet
set [ find default-name=ether1 ] name=E1:AIS_FIBRE
set [ find default-name=ether2 ] name=E2:LAN02
set [ find default-name=ether3 ] name=E3:LAN03
set [ find default-name=ether4 ] name=E4:LAN04
set [ find default-name=ether5 ] name=E5:LAN05

/interface vlan
add interface=E1:AIS_FIBRE name=AIS_VLAN10 vlan-id=10

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik

/ip pool
add name=LAN_Pool01 ranges=10.55.55.1-10.55.55.240

/ip dhcp-server
add address-pool=LAN_Pool01 disabled=no interface=LAN_bridge01 lease-time=1w name=DHCP_HOME

/ppp profile
set *FFFFFFFE dhcpv6-pd-pool=AIS_IPv6 use-ipv6=required use-upnp=yes

/interface pppoe-client
add add-default-route=yes disabled=no interface=AIS_VLAN10 name=pppoe-out1 password=xxxxxx profile=default-encryption use-peer-dns=\
yes user=8800xxxxxx

/interface bridge port
add bridge=LAN_bridge01 interface=E5:LAN05
add bridge=LAN_bridge01 interface=E4:LAN04
add bridge=LAN_bridge01 interface=E3:LAN03
add bridge=LAN_bridge01 interface=E2:LAN02

/ip settings
set accept-redirects=yes accept-source-route=yes

/ipv6 settings
set accept-router-advertisements=yes

/ip address
add address=10.55.55.254/24 interface=LAN_bridge01 network=10.55.55.0

/ip dhcp-server network
add address=10.55.55.0/24 dns-server=10.55.55.254,8.8.8.8 gateway=10.55.55.254 netmask=24 ntp-server=10.55.55.254

/ip dns
set allow-remote-requests=yes cache-max-ttl=1d cache-size=5000KiB max-concurrent-queries=1024 max-concurrent-tcp-sessions=2048 \
max-udp-packet-size=40960 query-server-timeout=3s

/ip firewall mangle
add action=accept chain=forward in-interface=pppoe-out1
add action=accept chain=forward out-interface=pppoe-out1

/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1

/ipv6 address
add from-pool=AIS_IPv6_Pool interface=LAN_bridge01

/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 pool-name=AIS_IPv6_Pool request=prefix

/ipv6 nd
set [ find default=yes ] advertise-dns=yes hop-limit=64 mtu=9000 other-configuration=yes ra-lifetime=10m reachable-time=10s \
retransmit-interval=10s

/system clock
set time-zone-name=Asia/Bangkok

/system ntp client
set enabled=yes primary-ntp=103.22.182.121

ทดสอบในส่วนของเครื่อง client ก็มีได้รับ dhcp ดังรูปที่ 7 ครับ

รูปที่ 10 แสดงค่า IPv6 address บนเครื่อง client

หลังจากนั้นผมได้ทำการทดสอบความเร็วของ Internet ที่ได้ เป็นน่าพอใจเลยทีเดียวครับ ตามรูปที่ 11 ทดสอบ 5 ครั้งได้ speed ที่เกินความคาดหมายทุกครั้งครับ

รูปที่ 11 ผลการทดสอบความเร็วของอินเตอร์เน็ต 5 ครั้ง

ทดสอบการการตั้งค่า IPv6 จากเว็บ test-ipv6.com จะได้ผลดังรูปที่ 12 และหลังจากนั้นทดสอบการ ping6 เพื่อ ping ไปยัง server IPv6 อื่นๆ เช่น ipv6.google.com www.facebook.com ได้ผลดังรูปที่ 13

รูปที่ 11 ทดสอบ IPv6 ด้วยเว็บ www.test-ipv6.com
รูปที่ 12 ทดสอบ ping6 ไปยัง IPv6 อื่นๆ เช่น ipv6.google.com, www.facebook.com


สิ่งที่ต้องศึกษาเพิ่มเติม

1. ทำไมบน LAN ของ Client มี IPv6 หลาย prefix?
2. ต้องใช้เวลาศึกษา IPv6 ให้มากกว่านี้เพิ่มขึ้น เพื่อนำไปต่อยอดในการใช้งานในอนาคต

ทิ้งคำตอบไว้

Please enter your comment!
Please enter your name here